CodeQL documentation

Access to unsupported JDK-internal API

ID: java/jdk-internal-api-access
Kind: problem
Severity: recommendation
Precision: high
Tags:
   - maintainability
Query suites:
   - java-security-and-quality.qls

Click to see the query in the CodeQL repository

Java 9 removes access to various unsupported JDK-internal APIs by default.

Recommendation

Examine the use of unsupported JDK-internal APIs and consider replacing them with supported APIs as recommended in the references.

References