CodeQL library for Java/Kotlin
codeql/java-all 0.9.0 (changelog, source)
Search

Predicate javaApiCallablePasswordParam

DEPRECATED: Use the PasswordSink class instead. Holds if callable c from a standard Java API expects a password parameter at index i.

Import path

import semmle.code.java.security.SensitiveApi
predicate javaApiCallablePasswordParam(Callable c, int i)